Bacs News Letter: "Internet security is changing – don't hide from it"

The recent Bacs newsletter highlights important changes to internet security. There is no need to worry about these changes as we will be issuing updates to our products over the next year to insure that your system is fully compliant.

Windows XP, Vista, Server 2003 and 2008 do not support TLS 1.1 and 1.2, so it will be essential that these operating systems are upgraded if our products are running on them. Currently supported Operating Systems are Windows 7 onwards, and Windows Server 2008 R2 onwards.

If you have any questions please don’t hesitate to contact support.

Last Updated: 19/10/15